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LDAP Listener remains in incorrect status Active (Shutting Down)

Problem

LDAP Monitor shows the LDAP Listener with the incorrect status Active (Shutting Down)

Symptoms


This problem can occur after an abnormal termination of the LDAP Listener process or after a ServiceNow upgrade.

  • Restarting the LDAP Listener does not change the status.
  • In some cases the LDAP Listener is still functional.
  • Entries appear in the sys_status table such as ''glide.ldap.listener-790e96360a0a3c7000794f76ff93305a.shutdown_pending''

Cause


The table sys_status contains additional entries that have not been cleaned up.

Resolution


To resolve this issue:

  1. Navigate to each LDAP Server and click Stop Listener.

  2. Delete the *glide.ldap.listener entries in the sys_status table.

    1. Enter sys_status.list in the filter.

    2. Search for the name *glide.ldap.listener.

    3. Delete the entries.

  3. Navigate to each LDAP Server and click Start Listener.

Note: This process does not cause any down time or negative performance for the ServiceNow application. It is completely transparent to any users logged in and working.

 

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Article Information

Last Updated:2019-05-21 11:50:28
Published:2018-01-19