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Windows Server error "Access is denied (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))" - Support and Troubleshooting
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  • Windows Server error "Access is denied (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))"
KB0564283

Windows Server error "Access is denied (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))"


86739 Views Last updated : May 21, 2025 public Copy Permalink English (Original)
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KB Summary by Now Assist

Issue

The Windows Server error "Access is denied (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))" is returned when running a Discovery, Orchestration, or IntegrationHub step. This article contains a list of issues and resolutions that SN support has come across while troubleshooting "Access is denied" errors.

An environment configured to allow communication between the MID server and the target server, and a credential with the necessary rights, are prerequisites in order for Powershell probes to execute successfully. It is often necessary to reach out to the windows team managing the target server to resolve such access issues.

Release

All

Cause

  • Incorrect credentials configured for target Windows Server
  • The credential used for the discovery of this Windows Server does not contain the domain name
  • Credential permissions
  • Windows Management Instrumentation (WMI) is disabled or not configured properly on the target Windows Server
  • WMI permissions
  • WMI-related service or services are disabled
  • EnableDCOM registry entry that controls the global activation and call policies is disable either on the MID Server or on the target Windows Server.
  • Execution policy on target server does not allow scripts to be run
  • Target server does not allow remote execution

Resolution

Incorrect credentials configured for target Windows Server

Verify that the user name and password for the Windows Server are correct:

    1. Log in to the Windows Server that you must discover using a remote desktop connection.
    2. If you fail to connect, the username and password for this Windows Server are wrong. Find out the correct credentials and configure them as described in the Service Mapping documentation. If you connect successfully, continue with this troubleshooting procedure.

The credential used for the discovery of this Windows Server does not contain the domain name

Perform the following steps:

    1. Navigate to MID Server > Credentials.
    2. Click the Windows credentials configured for the Windows Server you failed to access.
    3. Check that the Windows Server credentials contain the domain name. The domain name appears in front of the user name and is separated with blackslash (\).

Domain name part of user name

4. If not, add the relevant domain name to the credentials. Use the domain name which allows you to access this Windows Server.

Credential permissions

For information on permissions, review the following documentation:

    • Windows credentials
    • Windows probes and permissions

Windows Management Instrumentation (WMI) is disabled or not configured properly on the target Windows Server

Check that Windows Management Instrumentation (WMI) is enabled by performing the following steps:

    1. On the Windows Server, navigate to Start > Run.
    2. Enter wbemtest.
    3. Check that the Windows Management Instrumentation Tester application starts.
      If it does, WMI is enabled.
    4. In the Windows Management Instrumentation Tester window, click Connect.
    5. In the Connect window, leave the default values for Namespace and Credentials and click Connect.
    6. Click Query.
    7. In the Query window, enter the following WMI query:
      Select * from Win32_ComputerSystem and click Apply.
    8. Verify that you get a reply with the computer name.

WMI permissions

Ensure that all WMI-related services can be started on-demand:

    1. In the Windows Explorer, navigate to Server Manager.
    2. In the tree, select Configuration, right-click WMI Control, and select Properties.
    3. In the WMI Control Properties window, click Security.
    4. Click the Root folder and click Security.
    5. In the Security for Root window, click Advanced.
    6. In the Advanced Security Settings for Root window, double-click Administrators.
    7. In the Permission Entry for Root window, verify that all checkboxes are selected.

WMI-related service or services are disabled

  1. In the Server Manager, select Configuration > Services and verify that the status for the following services is not disabled:
    • Remote Access Auto Connection Manager
    • Remote Access Connection Manager
    • Remote Procedure Call (RPC)
    • Remote Procedure Call (RPC) Locator
    • Remote Registry
    • Server
    • Windows Management Instrumentation
    • Windows Management Instrumentation Driver Extensions
    • WMI Performance Adapter

EnableDCOM registry entry that controls the global activation and call policies is disable either on the MID Server or on the target Windows Server

Perform the following steps both on the MID Server and on the Windows Server to verify that DCOM is enabled on both servers:

    1. Navigate to the registry.
    2. Check the following registry entry on both computers:
      Key: HKEY LOCAL MACHINE\Software\Microsoft\Ole
      Name: EnableDCOM
      Type: REG_SZ
      Data: Y

Execution policy on target server does not allow scripts to be run

Ensure the execution policy is set accordingly. See following documentation for requirements:

    • PowerShell for Discovery and Service Mapping

Following Microsoft documentation goes over how to check the execution policy and how to set it:

    • Get-ExecutionPolicy
    • Set-ExecutionPolicy

Target server does not allow remote execution

Enable remote execution:

    • Enable-PSRemoting

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