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Resolving issue of RPC Server unavailable during Windows Server discovery in Service Mapping - Support and Troubleshooting
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  • Resolving issue of RPC Server unavailable during Windows Server discovery in Service Mapping
KB0564282

Resolving issue of RPC Server unavailable during Windows Server discovery in Service Mapping


19948 Views Last updated : Jul 24, 2025 public Copy Permalink English (Original)
  • English (Original)
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KB Summary by Now Assist

Issue

  • The business service map displays the warning icon (Warning icon) on top or instead of the Windows Server.
  • The following error message displays for the Windows Server: 
    RPC Server unavailable

Cause 1

Service Mapping is trying to access this Windows Server using an incorrect IP address.

The Windows Server has multiple IP addresses. Service Mapping automatically discovered only one of the IP addresses and therefore is not listening on the full range of ports. Typically, Service Mapping discovers and listens only to the application port.

Resolution 1

Perform the following steps:

  1. On the map, right-click on the discovery error message and select Add Management IP.
  2. Select one of the IP addresses of this Windows Server.
  3. Verify that the discovery and mapping process is completed without errors. 

Cause 2

A firewall blocks Remote Procedure Call (RPC) calls from the MID Server to the Microsoft Windows Server preventing the discovery process. The problem can be caused either by Windows Firewall (embedded) or an external firewall.

The firewall is not configured correctly to let through RPC calls from the MID Server. Typically, RPC uses a large range of ports. The MID Server initiates the RPC connection on port 135, but once the connection is established, it uses any port in the range of 1024 and up.

Resolution 2

Perform the following steps to verify that the firewall blocks RPC calls:

  1. On the MID Server, run the following command:
    wmic /NODE:target_server_ip_address /user:domain\user /password:xxxx cpu get
  2. Check the result. If you get the message that the RPC Server is unavailable, it means that the firewall between the MID Server and the Windows Server is blocking the connection. If you do not get an error message, carry on with the next step.
  3. If the Windows Server has embedded Windows Firewall, disable it temporarily and run the same command from the MID Server:
    wmic /NODE:target_server_ip_address /user:domain\user /password:xxxx cpu get
  4. If you get the success message, you must configure the embedded Windows Firewall to let through RPC calls from the MID Server.

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