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Instance does not redirect to the OKTA site when the "Click here to log in with Okta, Inc." link is used

 

Problem
After activating and configuring the SSO Provided by OKTA plugin and the Servicenow tenant in OKTA, the "Click here to log in with Okta, Inc." link on the instance does not redirect to the OKTA site

 

Symptoms
Internet Explorer displays an error saying that the page could not be loaded in a frame. Firefox and Chrome display an error about "Same-Origin Policy" in their debugging tools.

  

Cause
The link in Servicenow instances resides on a page within an iFrame of the instance. There is a configuration in OKTA that prevents the site from being loaded in an iFrame

 

Resolution
The following support article in OKTA addresses this issue:
  1. Login into OKTA tenant as an admin.
  2. Navigate to Settings > Customization.
  3. Locate IFrame Embedding.
  4. Click Edit.
  5. Select the Allow IFrame embedding option.

Article Information

Last Updated:2017-03-24 11:28:37
Published:2017-03-24