CMS links on search results are updated after right-clicking or opening on a new tab.

Steps to Reproduce


  1. Launch CMS by navigating to https://<instance>.service-now.com/ess.
  2. In the global search box (top right) type "test."
  3. Hover over one of the results in the group "Change."
    Look carefully at the link in the browser status bar at the bottom of screen. It displays the link as expected, for example https://<instance>.service-now.com/ess/change_request.do?sys_id=a9e9c33dc61122760072455df62663d2.

  4. Right-click on CHG####### to display the browser context menu and select Open in New Tab (or just click in an empty area (to get rid of the context menu).
  5. Hover over the same record.
    Look carefully at the link, it has changed to:

  6. Now if you click on the record within the search results page, the message Detail record could not be located appears.

    The issue applies to all links on the result page. The first click correctly opens the content type related to the link/record. The second click opens the DEFAULT content type instead, which does not find the record as the document key is undefined.


There is no known workaround for this issue. If you are able to upgrade, review the Fixed In field below to determine the versions that have a permanent fix to this issue.

Related Problem: PRB616656

Seen In

Dublin EA 1
Geneva Patch 5
Geneva Patch 6
Geneva Patch 7

Fixed In


Associated Community Threads

There is no data to report.

Article Information

Last Updated:2017-06-28 07:20:37