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Shopping Cart not displayed in Service Catalog on CMS site

 

Problem
Users within a CMS site do not have a shopping cart when searching categories.



Also, when they drill into an item they do not see the cart or buttons displayed on the cart (Order Now, Add to cart ,or Continue Shopping).

Symptoms
CMS users do not see a shopping cart when searching Service Catalog categories. User can select a catalog item, but there is no method to request an item as the following are not displayed:
  • Shopping cart
  • Order Now button
  • Add to Cart button
  • Edit Cart button
  • Proceed to Checkout button
  • Continue Shopping button

The issue only affects the CMS Service Catalog. The issue does not occur within the non-CMS Service Catalog.

 

Cause
This is a CMS configuration issue. A CMS Site record has a Use external cart option that omits the default cart when rendering catalog pages within a site that contains catalog pages. 

 

Note: If you use an external cart, the no cart option on a service catalog item has no effect. The external cart appears for all items.

 

If the site record has the Use external cart option selected, a block needs to be included in the site so users can interact with their catalog cart. For more information, see Catalog Cart Block in the product documentation.

Resolution
  1. Navigate to Content Management > Sites.
  2. Select site record of the CMS site that has the issue.
  3. Ensure the that Use external cart option is not selected.
  4. Retest and verify that users see the Shopping Cart as expected when searching within catalog categories.



    Users should also see the Shopping Cart when selecting an item.

For more information about the external cart feature, see Create a Site in the product documentaiton.

Article Information

Last Updated:2017-03-16 17:19:51
Published:2015-10-08