602 views

Description

When a user receives an email to take a survey, the link to the survey included in the email does not work on the mobile UI.

Steps to Reproduce

  1. Log into an affected instance as a maint or admin user.
  2. Open the following link, replacing <instance> with the name of the instance being used. This is an out of box survey and should be available on any instance.
    <instance>.service-now.com/nav_to.do?uri=survey_take.do?sysparm_survey=Service%20Desk%20Satisfaction%20Survey%26sysparm_task_survey=bf986a946f7421008ba142dbea3ee462
  3. You are redirected to the Service Desk Satisfaction Survey page.
  4. Access the instance via the Mobile UI ($m.do).
  5. Paste the same URL, again replacing <instance> with your instance name:
    <instance>.service-now.com/nav_to.do?uri=survey_take.do?sysparm_survey=Service%20Desk%20Satisfaction%20Survey%26sysparm_task_survey=bf986a946f7421008ba142dbea3ee462

The link should direct to the Survey as it does in step 2, but the link actually goes to the mobile homepage.

 

Workaround

This issue is under review. If you are able to upgrade, check the Fixed In field below to determine the versions that have a permanent fix. You can also subscribe to this known error article (click Subscribe button at the top of the article) to receive notifications when more information is available about this issue.


Related Problem: PRB601386

Seen In

Berlin Hot Fix 5
Dublin EA 8
Dublin Patch 7 Hot Fix 2
Eureka Patch 10 Hot Fix 1
Eureka Patch 2
Eureka Patch 4 Hot Fix 1
Eureka Patch 6
Eureka Patch 9
Fuji Patch 1
Fuji Patch 10
Fuji Patch 7 Hot Fix 5

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2017-06-27 10:51:11
Published:2017-06-27