Performance can be slow and lag in UI15 when using Internet Explorer 9. High CPU usage toward 100% is seen often.

Steps to Reproduce

IE9 was released several years ago and is not a recent modern browser. The new features in UI15, combined with a complex system configuration, may cause IE9 to become slow while loading pages or performing some operations. This slowness is due to the time that IE9 spends loading the pages, and does not necessarily mean that the ServiceNow instance has a performance degradation.

Development has made the decision to include IE9 with UI15 due to the large number of customers using it. They wanted to ensure all of the new functionality in Fuji would have a wide customer base upon release. A customer can weigh the performance impact against the benefits of using Fuji and decide if they want to disable it for IE9.




  • No workaround is really effective in IE9
  • If IE10 needs to be used, set glide.ui.doctype.ie_version to 10
  • Additionally, if the new UI14-15 interface is not wanted, set the glide.ui.doctype property to false

Related Problem: PRB630097

Seen In

Eureka Patch 10
Eureka Patch 2
Eureka Patch 8
Eureka Patch 9
Fuji Patch 2 Hot Fix 1
Fuji Patch 3
Fuji Patch 4 Hot Fix 4
Fuji Patch 5
Fuji Patch 6
Geneva Patch 1
Helsinki Patch 1 Hot Fix 1

Associated Community Threads

Community ThreadTitleResponsesUpvotes
https://community.servicenow.com/thread/183475Fuji Upgrade Issues and Experience

Article Information

Last Updated:2017-10-30 13:20:48