Issue
Symptoms:
Field is missing on the form.
Field/Attachment/Choice Field/Button on a form does not appear/does not display/not visible/not showing/not editable/unavailable/missing/lost/can't see/unable to view/grayed out.
Release
All
Cause
Access controls for read rights are not granting access to a field.
-- The user does not meet the filter condition of the ACL.
-- The user does not meet the script condition of the ACL.
-- The user does not have the defined roles of the ACL.
Resolution
The first step to identifying a field not appearing on a form as an ACL issue is to use the debug security option to see if any ACL restrictions are occurring. Let's take the example of the work_notes field which is on the task table (and extended tables).
- To start with as an admin role user you will login and go to System Diagnostics -> Session Debug -> Debug Security.
- Impersonate a user that cannot see the field. In this case Joe Employee.
- View an affected record (incident in this case).
A large amount of security related statements will be displayed below the record. - Search for the field and operation (read, write, etc) that you are interested on the page by using the browser's search page function. In this case we search for work_notes/read. You should see an entry that looks like this:
- Click the link that is next to the failing ACL to open it in a separate tab. In this case the link text is record/task.work_notes/read.
Note: You will not be able to view the ACL because you are still impersonating a non-admin user.
- Switch back to your admin user account and refresh the tab with the ACL in it.
- You can now see the ACL that is failing. Update this ACL script, condition, or filter values to allow access.
Related Links
Community Article
https://community.servicenow.com/community?id=community_blog&sys_id=e235c06cdbe7d050b1b102d5ca9619d7
Product Documentation