Issue
Problem
The client script is disabled, affecting the ability to set a UI policy to a form.
Symptoms
-
Cannot change field
-
UI policy not working
-
UI action not working
-
Client scripts not working
-
Fields not visible
-
Mandatory field not working
Cause
Client scripts are manipulating the fields you are trying to set with a UI policy. For example, if a client script changes field A to a different value, and that causes a condition to no longer be true in a UI policy, then the UI policy no longer fires.
Resolution
When UI policies are not working as expected, it is a good idea to check if there are client scripts (or catalog client scripts if appropriate) that are manipulating the fields.
For example, if you are trying to set the caller_id field to mandatory in an incident with a UI policy, you can check for client scripts that might be affecting this field following the steps below:
- Go to client scripts (or catalog client scripts).
- Filter the breadcrumbs as follows:
Table is incident
and
script contains caller_id - Review the scripts to see if they might be conflicting with your UI policy.
- If no matches are found, revise the search to see if the script field contains a field that is being used in the condition of your UI policy. For example, if your UI policy for the caller_id field was checking the category field as part of the condition, then do a client scripts search where:
Table is incident
and
script contains category - If other fields are part of your UI policy condition, check those in the same manner.