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Determining whether missing ACLs are causing access issues with ODBC queries - Support and Troubleshooting
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  • Determining whether missing ACLs are causing access issues with ODBC queries
KB0542655

Determining whether missing ACLs are causing access issues with ODBC queries


1584 Views Last updated : May 19, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Determining whether missing ACLs are causing access issues with ODBC queries

 

Symptoms
  • Query returns error message
  • Queried returns table column names but not values
  • Query does not allow read access
 
Cause
There are no ACLs defined for a table to allow access to the user. If ACLs are not defined, the default is to deny access to the user without the admin role.
Resolution

You may receive this error message when running an ODBC query:

[DataDirect][ODBC OpenAccess SDK driver][OpenAccess SDK SQL Engine]Could not find any column information for table:<table_name>.[10131]

To allow read access, add an ACL for a particular role, and add that role to the user record. The odbc role is provided by default starting with Helsinki. Make sure to verify and add all necessary ACLs.

 

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