Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
ODBC Error Messages: Determining if your query needs to be refined - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • ODBC Error Messages: Determining if your query needs to be refined
KB0538981

ODBC Error Messages: Determining if your query needs to be refined


2229 Views Last updated : Apr 8, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

ODBC Error Messages: Determining if your query needs to be refined  

Symptoms:

  • query timed out while processing
  • driver times out waiting for a response

Cause

If you receive an error message that your query did not return in the expected amount of time, it is likely that the query was too general and timed out while processing.

Resolution

If you receive the following error message when running an ODBC query, 

[DataDirect][ODBC OpenAccess SDK driver][OpenAccess SDK SQL Engine] 

Error Message: Method failed: (https://myinstance.service-now.com/mytable.do?SOAP&displayvalue=all) HTTP/1.1 502 Bad Gateway with code: 502 

Your query did not return in the expected amount of time. Please limit your query and try again., the query you have issued timed out while processing. Normally, the Apache web server serving your instance's web service has a default timeout set at 5 minutes. When a request requires more than 5 minutes to process, the error message appears. 

Refine your query by adding more filter conditions. Avoid multi-table joined aggregate queries whenever possible. Instead, issue a query against a pre-defined database view.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.