Notifications

1620 views

Determining if you have the latest ODBC driver version

  

Symptoms
  • Cannot connect to the instance
  • Error message received during processing
  • Queried information lost
  • Precision errors received
  • Connection dropped
 
Cause
A common cause of ODBC driver issues is not having the latest ODBC version installed. If you do not have the latest version, uninstall the old version and install the new one.

 


Resolution
To verify that your instance is running the latest ODBC version, check the build date and time of the ODBC driver. To do this, use CheckVersion located in the Service-Now\ODBC\ip\tools folder. This is an executable Windows host script that reports the build date and time of the current ODBC driver. Use the scrpt to determine which build of the ODBC driver is running. If the CheckVersion tool is absent, the ODBC driver is out of date and should be uninstalled and reinstalled. For more information, see ODBC Driver in the ServiceNow product documentation.

Starting with the ODBC driver version 1.0.9 you can view the version of the installed driver in the Microsoft Windows Programs And Features control panel.

Prior to ODBC driver version 1.0.7.1, the only way to identify the version is:  

1. Go to <installations_folder>\ODBC\ip\oajava\service_now

2. Open glide-odbc.jar as an archive. 

3. Navigate to META-INF folder. 

4. Open MANIFEST.MF file. 

5. Look for the buildVersion or Implementation-Version property. 

Article Information

Last Updated:2016-09-20 08:51:20
Published:2014-06-12