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Troubleshooting export - Determine if the configured maximum rows to export is too low - Support and Troubleshooting
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  • Troubleshooting export - Determine if the configured maximum rows to export is too low
KB0538324

Troubleshooting export - Determine if the configured maximum rows to export is too low


11903 Views Last updated : Mar 6, 2025 public Copy Permalink English (Original)
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KB Summary by Now Assist

Issue

This issue is related to exporting data from the instance while obtaining only a subset of the data from the expected results.

Symptoms

  • Not all data is exported
  • Records are missing from export

Cause

The setting for the maximum rows to export for the file type (CSV, XML, Excel, or PDF) is too low.

For Excel, another cause can be the setting for the maximum number of cells to export is too low. For more information, see Export Limit/Max Overview (Excel, CSV, PDF, Database Views)

 

Resolution

To solve the issue, set the limit property for the file type to a higher value.

For example, by default, the limit for CSV export is 10,000 records. If you need to export 15,000 records, you can set (or add if not exists) the 'glide.csv.export.limit' system property to change the limit to 15,000 which is mentioned in KB0695242. Details about other glide.csv, glide.excel and glide.pdf system properties can be found here.

For more information about export limits and how to override them, see Export Limits

 


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