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Troubleshooting export - Determine whether the encoding setting is wrong - Support and Troubleshooting
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  • Troubleshooting export - Determine whether the encoding setting is wrong
KB0538309

Troubleshooting export - Determine whether the encoding setting is wrong


6105 Views Last updated : May 1, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

  • Export results are formatted with the wrong encoding
  • Non-English characters (for example, Russian, Hebrew) are replaced by question marks

Cause

The setting for the export encoding is missing or it has the wrong value. This issue is related to exporting data using the CSV format from the instance.

Resolution

To solve the issue, set the correct encoding using the system property glide.export.csv.charset

Note: By default, ServiceNow exports all CSV files in Windows-1252 encoding. If you need to export translated data, set the glide.export.csv.charset system property to UTF-8 (starting with the Calgary release).

 


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