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Determining if a business rule is running on top of the transform map - Support and Troubleshooting
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  • Determining if a business rule is running on top of the transform map
KB0538161

Determining if a business rule is running on top of the transform map


6092 Views Last updated : Oct 20, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Determining if a business rule is running on top of the transform map 

 

Problem

Records are not being created or updated in a timely manner on the instance.

 

Symptoms
  • Associated transform takes longer than expected
  • Overall performance on the instance is lower when the import occurs

  

Cause
Various business rules are being run when the import is performed.

 


Resolution
For large imports (10,000 to 100,000), it is advised to disable business rules. To do this: 
  • Locate the particular data source that appears to be causing the issue.
  • In the Transforms section, click the desired link to view the associated Transform Map.
  • Within the Transform Map record, locate the Run Business rules property and clear the associated checkbox.

 

Note: Consider using an onComplete transform script to run business logic, such as calculations, at the end of an import rather than on each record the way business rules do.

 


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