Notifications

792 views

Description

After an attribute on a table is set to remove the display value, it continues to remove this value even when converted to its default format. Even if you specify that the display value should be present, it does not appear.

Steps to Reproduce

 

  1. Navigate to Incident > Open.
  2. Select any record.
  3. Clear out the value in the Caller field, if anything is present, and enter the letter a.
    Note that the Display value (Full Name) and Email displays.



  4. Navigate to User Administration > Users.
  5. Right-click on the header and navigate to Personalize > Dictionary.
  6. Select the sys_user option with no Column name and the Collection Type.
  7. Switch to the advanced view.
  8. Add the following to the end of the Attributes field: ,ref_ac_display_value=false
    The full value should be the following: iterativeDelete=true,ref_ac_columns_search=true,ref_auto_completer=AJAXTableCompleter,ref_ac_columns=email,ref_ac_order_by=name,ref_ac_display_value=false
  9. Click Save.
  10. Navigate back to Incident > Open, and open the record you had previously.
  11. Type in a in the Caller field again, and only the email appears in the Autocomplete.



  12. Navigate back to User Administration > Users, and Personalize the Dictionary again. Select the sys_user Collection record.
  13. Switch to the advanced view.
  14. Revert the change you made by removing ,ref_ac_display_value=false from the attributes.
  15. Click Save.
  16. Navigate back to Incident > Open, and open the record you had previously.
  17. Type in a in the Caller field again, and only the email appears in the Autocomplete, despite the default value being to include the display value.



  18. Navigate back to User Administration > Users, and Personalize the Dictionary again. Select the sys_user Collection record.
  19. Switch to the advanced view.
  20. Add the following to the Attributes field to add back in the Display value: ,ref_ac_display_value=true
  21. Navigate back to Incident > Open, and open the record you had previously.
  22. Type in a in the Caller field again, and only the email appears in the Autocomplete, despite specifically specifying to include the display value.

Workaround

  • Running GlideCacheManager.invalidate(); as a background script updates the display value
  • Restarting the instance enables the display value to appear again (note that instance restarts can only be scheduled by filing an incident with ServiceNow Customer Support)

Related Problem: PRB583881

Seen In

Berlin Hot Fix 5
Calgary Patch 6
Eureka Patch 8

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2017-05-18 10:41:04
Published:2013-05-27
Autocomplete After Change.pngAutocomplete After Revert.pngAutocomplete Before Change.png