671 views

Changes are not saved after updating a form record




Symptoms
  • Changes are not saved after updating a record, such as an incident or problem. No visible errors, security constraints, or messages appear.
  • When saving a record, the user is redirected to a new record form.

 

Cause

Form data in the HTTP request has exceeded the maxPostSize limit of 2MB (default) for Apache Tomcat. 

 

Solution

 

Note: The following steps only apply to single entries into fields. They do not apply, for example, to a case where there are several small work notes or comment entries. The HTTP request form data does not include all the journal fields every time. It only includes recent work notes and comments.

 

 

To save the information to a text file and remove most of the data in the field:

    1. Tail the logs and you will find an entry similar to the one below: 

      2013-04-29 15:04:20 (023) http-15 C4E47CA918490DC0D04A1582CF1D0FE5 Parameters -------------------------
      2013-04-29 15:04:20 (024) http-15 C4E47CA918490DC0D04A1582CF1D0FE5 *** Start #3,770,834, path: /incident.do, user: Your.Name@snc
      2013-04-29 15:04:20 (026) http-15 C4E47CA918490DC0D04A1582CF1D0FE5 WARNING *** WARNING *** WithTag2 called with no query, returning a new record instead

    1. Avoid copying and pasting the headers for the request into a text file because the file will then exceed 2MB.

    1. Save the text file and attach it to the affected record.

  1. Find the fields that contain large amounts of text and truncate them to a reasonable size to (significantly smaller than 2MB).

Article Information

Last Updated:2016-03-21 07:43:28
Published:2013-04-30