Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unexpected choice options appear in a choice list field - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unexpected choice options appear in a choice list field
KB0517461

Unexpected choice options appear in a choice list field


4856 Views Last updated : Aug 22, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

An unexpected or incorrect set of choices appear in a choice list field.

Cause

When a choice list is dependent on the content of another field, mismatched parent and child values can cause unexpected choice options to appear in a choice list.

Resolution

A choice list is a type of field that allows the user to select from a pre-defined set of choices. Users can specify when the values of one field depend on the values of another field (parent field). This is accomplished by defining a dependent value in the choice record that sets its choice list based on the value of the parent field. If the choice list is dependent on another field, users must first enter the value of the parent field for dependent values to appear. 

For example, in the Incident form, Category is a parent field and Subcategory is a child field. First, the Category value on the incident must be selected and then the Subcategory choice list populates the set of choices. The Subcategory choice list is recalculated every time the Category value is changed. When the Category field is updated, the Subcategory values are refreshed to display the proper dependent values. For additional information, see Choice Lists in the product documentation.

To verify the choice list values are properly matched to the parent value:

  1. Navigate to the form that contains the choice list field you want to review.
  2. Right-click the dependent field label that is showing unexpected values and select Show Choice List.
    The Choice entries for all the parent field values are shown. Parent values are stored in the Dependent value field.

    Choice List Dependent Value

    Note: If the Dependent value column does not appear in the Choices list, use the Personalize List functionality to add the column.

    3. Use the Dependent value field to verify the dependent values are properly matched to the parent field. If these values do not match, make the appropriate changes to the affected records.
  3.  

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.