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Subscription-based notifications are not working 

 

Note: The functionality of the "subscribable" checkbox has changed over time. This article was written for versions prior to Aspen.

For a good description of how they currently work, see Jonny Seymour's blog post https://community.servicenow.com/community/service-automation-platform/notifications/blog/2015/11/26/notifications-subscribable-vs-suscription-based

 

Symptoms


The subscribable checkbox has been checked, but Subscription-based notifications are not working.

 

 

Cause

The issue here is that there is a misunderstanding about what subscribable notifications are and how they work. The confusion stems from the difference betweent two terms: "Subscription Based Notifications" and "Subscribable Notifications" These are actually two separate functions. 

1. Subscribable Notifications (ones with the check box checked) build their recipient lists through complex relationships between pieces of the application. For instance, a subscribable notification may be set up to notify network support groups who may be impacted by a network issue that occurs on an upstream and/or downstream network item. The notification list is built by checking which other items are connected to the effected configuration item.

2. Subscription Based Notification is the functionality that you want and it refers to a mechanism that allows users choose which Notifications that they would like to receive and which ones they don't want. You do not need to check the "subscribable" checkbox to get this functionality. In fact, if you click that checkbox, it will break the notification.

The following product documentation pages can assist you with implementation:

 


Resolution


Uncheck the subscribable checkbox.

 

Article Information

Last Updated:2016-12-20 08:12:06
Published:2011-11-03